[OPEN-ILS-GENERAL] Evergreen 1.4 install problems after running staff client -

Robert Soulliere robert.soulliere at mohawkcollege.ca
Tue Nov 4 09:05:58 EST 2008

I found the solution to this problem. First I reinstalled, then I found
a post from "Lyons, Cyrus 2" <lyonsc2 at lsbu.ac.uk> Who had helped me
previously with this issue in older versions of Evergreen. I should have
looked for this old post when I had encountered this again. Here is what
he posted just in case anyone encounters a similar problem with version
errors in the staff client:

No problem. I had the same initial issue with my fresh Etch install
recently. The problem seems to be resolved (this is not a fix I've
checked with anyone; just a hunch I followed through) if you create a
symlink to the xul build directory and call it whatever the client is
hoping to find.
One solution for this is to build the Staff Client from source with
the versionless flag, but this is apparently now deprecated. Instead,
I symlinked the server directory to a different name:
root at evergreen:/openils/var/web/xul# ln -s
/openils/var/web/xul/20080723.124351 /openils/var/web/xul/rel_1_2_2_3.
The directory 20080723.124351 contains my build of the server; it is
named as such because that's when the build was run (I presume). This
is server version, and the Staff Client, also being version, is designed to connect to the rel_1_2_2_3 build. Thus, the
symlink makes it appear as though the 20080723.124351 build is in fact
simply rel_1_2_2_3.
It's simple enough to check which versions you need to use -- navigate
to /openils/var/web/xul and do an ls to find out what your build is
called; then open up the Staff Client and hit "About this client..."
and check the Target Server ID near the top to find out what your
symlink should be called. Note that since this seems to me to be a
workaround, rather than a fix, you should probably check that your
staff client is in fact the same version as the server. Not sure about
that - just a guess.

This solution worked for me both in Debian (Evergreen 1.2) and Ubuntu
8.04 (Evergreen 1.4). 

Thanks again Cyrus!

----- Original Message -----
From: Robert Soulliere <robert.soulliere at mohawkcollege.ca>
Date: Thursday, October 30, 2008 11:06 am
Subject: Evergreen 1.4  install problems after running staff client
To: Evergreen Discussion Group <open-ils-general at list.georgialibraries.org>

> I was able to install Evergreen on Ubuntu following the the 
> instructions.I was able to test with srfsh
> The OPAC worked. 
> However, I ran into problems once I installed and ran the staff client
> (http://open-ils.org/downloads/evergreen-setup-rel_1_4_0_0_rc1.exe).
> When I ran the server test from the client, the server connection was
> "OK", but the version verification failed. 
> I assumed the problem related to step 5.III "make
> STAFF_CLIENT_BUILD_ID=rel_1_4_0_0 install" 
> I thought I ran this step exactly as written, but wondered if the 
> buildID needed to be  "rel_1_4_0_0_rc1" which is the title of the 
> clientwindow. So I ran the command "make 
> STAFF_CLIENT_BUILD_ID=rel_1_4_0_0_rc1install" (probably a big 
> mistake in retrospect.)
> My other possible misstep is that I tried out the My account login in
> the web opac using the admin user. At which point I was asked to 
> changemy password for "admin" which I did. (probably another big 
> mistake). 
> As well as the staff client not working, the srfsh test does 
> returns an
> error "Unable to commincate with service open-ils.auth"
> Running Settings-tester.pl does not return any errors.  
> My questions are:
> 1. Is step 5.III where the server connection version problem being
> caused or was there another potential issue?
> 2. Has changing the admin password caused any issues or is that OK as
> long as I remember to use the new password?
> 3. Do instructions to restore the database on the page: 
> http://www.open-ils.org/dokuwiki/doku.php?id=evergreen-
> admin:importing:bibrecordsstill work for version 1.4?
> 4. Is there a step I could go back and start from to get back to a 
> goodinstall, or do I start from scratch?
> Thanks,
> Robert

This E-mail contains privileged and confidential information intended
only for the individual or entity named in the message.  If the reader
of this message is not the intended recipient, or the agent responsible
to deliver it to the intended recipient, you are hereby notified that
any review, dissemination, distribution or copying of this communication
is prohibited.  If this communication was received in error, please
notify the sender by reply E-mail immediately, and delete and destroy
the original message.

More information about the Open-ils-general mailing list