[OPEN-ILS-GENERAL] importing authority records - Vandelay in general

Cynthia Williamson crwbookgirl at gmail.com
Fri Dec 4 14:29:42 EST 2009

Hi All - I can report something similar to what happened to Repke but with
batch importing of MARC records rather than authority files.  It looks like
nothing has imported, as Repke says, progress bar sits at 0% - but when I
search for the records, they are there. I have also had to leave "Batch
Imported" and go back in again to "Inspect Queue" to see that things have
actually imported.  I haven't reported this before, because it doesn't
happen all of the time, sometimes things work exactly as they should.  Let
me know if I can supply more info.
Cynthia W.
Mohawk College
Hamilton, ON

On Fri, Dec 4, 2009 at 11:47 AM, Repke de Vries <repke at xs4all.nl> wrote:

> Hi Chris, hi Jason
> meanwhile Chris answered further [1]  but answering Jason's to keep the
> thread on this issue together.
> My library (evaluating Evergreen) is also struggling with (Vandelay)
> authority batch import and I have emailed this list on exactly the same
> phenomenon in  all fine 'till the actual import and a progress
> bar that sits still at 0 % and nothing getting imported.
> Chris: here are some results from trying the same on Dan Scott's
> virtual image [2] on my iMAC as an 1.6 implementation example and with  a
> small subset of  our IISH authority records for the bib record MARC 100
> field; this subset is available as test set in the Evergreen SVN [3]:
> 1) at first same story after selecting just one of the authority records
> and ask for Import Selected: progress bar sits at 0 % and just trying
> Validating or Right Mouse Click in a new bib record in the 100 field doesn't
> do anything
> 2) then I tried "Import all" and all of a sudden it did work and all 17
> records got reported as Imported (you have to leave the Batch Importer and
> go back to it again and to Inspect Queue etc. to actually see the change)
> and trying out in new bib record worked fine too
> 3) next trials were first a large set of  Authority MARC 400 records which
> did  upload but *not* import and then a small subset of the same (someone
> with SVN access could add that test set - let me know off list) which did
> *not* import either:  progress bar sitting for ever at  0 % (and nothing
> reported as imported)
> 4) however:  at some point I just tried to use it in a new MARC record and
> there they were the 400 authority data ??!!
> So: a dead progress bar sometimes means "nothing happened", sometimes it
> means nothing at all and authority data do find their way into the database.
> I have no clue what causes all this and inspected the Postgres database
> log, see no errors (I think) but lack the expertise to interpret what
> happens or does not happen at that level.
> Vandelay / batch importing authority records  seems an unpredictable roller
> coaster. Anybody ideas ?
> I can send you my  Postgres log or ay other of the EG logs.
> Repke de Vries, IISH
> [1] December first:
> "..
> Hi Jason,
> No, I haven't.  I'm just the cataloger at WJU, and Jeff, our IT guy who
> did our data migration and Evergreen installation, just accepted a job
> elsewhere.  Has anyone else had trouble with importing authority records
> in  Will upgrading to 1.6 solve this?
> Thanks,
> Chris
> .."
> [2] Downloadpage http://evergreen-ils.org/downloads.php   under "Other
> versions of Evergreen software"
> [3] called "auth-subset100.mrc" at http://svn.open-ils.org/trac/ILS/
> browser/trunk/Open-ILS/tests/datasets
> Op 1-dec-2009, om 17:24 heeft Jason Etheridge het volgende geschreven:
>  On Tue, Nov 24, 2009 at 11:51 AM, Chris Caughey <CCaughey at jessup.edu>
>> wrote:
>>> We were having trouble using the authority batch import.  The whole
>>> process
>>> would move along without incident until it came to the progress bar.
>>>  Then
>>> it would sit at 0% and do nothing indefinitely.  Last week, we upgraded
>>> to
>>>, and now the progress bar moves a little bit, but then it stalls
>>> out
>>> again.  Our IT department tells me that Evergreen is showing an error
>>> related to “arn_value.”  Has anyone else experienced this problem?  If
>>> so,
>>> what did you do to fix it?
>> Hey Chris, did you make any headway on this?
>> --
>> Jason Etheridge
>>  | VP, Tactical Development
>>  | Equinox Software, Inc. / The Evergreen Experts
>>  | phone:  1-877-OPEN-ILS (673-6457)
>>  | email:  jason at esilibrary.com
>>  | web:  http://www.esilibrary.com
>> Please join us for the Evergreen 2010 International Conference, April
>> 20-23,
>> 2010 at the Amway Grand Hotel and Convention Center, Grand Rapids,
>> Michigan.
>> http://www.evergreen2010.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://libmail.georgialibraries.org/pipermail/open-ils-general/attachments/20091204/f9d6e414/attachment.htm 

More information about the Open-ils-general mailing list