[OPEN-ILS-GENERAL] Evergreen error installing 3.1.1 - cannot connect to ftp mirror.datapipe.net

Jason Stephenson jason at sigio.com
Fri Aug 17 19:59:22 EDT 2018


Looks like you got a bad miror when cpan autoconfigured itself. This
isn't strictly an Evergreen issue, but I can help you with it.

Run the following command as root to start up CPAN:

perl -MCPAN -e shell

In the CPAN shell that opens, type the following:

o conf urllist pop
o conf urllist push http://www.perl.com/CPAN/
o conf commit

The above should get you a working mirror. You can then run the
prerequisite installation again.

You can find a current list of US CPAN mirrors, here:



On 08/17/2018 07:26 PM, JonGeorg SageLibrary wrote:
> Is anyone else having this issue when running the make command on
> evergreen 3.1.1 as root?
> When I run 'make -f Open-ILS/src/extras/Makefile.install ubuntu-xenial'
> it attempts to connect to
> ftp://mirror.datapipe.net/pub/CPAN/authors/01mailrc.txt.gz. as anonymous
> / blank. When I manually open ftp to that location whether via cmd or
> Filezilla it connects fine but the directory is completely empty at
> root, no pub directory, nothing. And I've tried this from different
> machines with different external IP's with the same result.
> Which then results in the following errors:
> Open-ILS/src/extras//install//Makefile.common:5: recipe for target
> 'install_cpan' failed
> make[2]: *** [install_cpan] Error 255
> make[2]: Leaving directory '/home/opensrf/Evergreen-ILS-3.1.1'
> Open-ILS/src/extras//install/Makefile.ubuntu-xenial:136: recipe for
> target 'all' failed
> make[1]: *** [all] Error 2
> make[1]: Leaving directory '/home/opensrf/Evergreen-ILS-3.1.1'
> Open-ILS/src/extras/Makefile.install:74: recipe for target
> 'ubuntu-xenial' failed
> make: *** [ubuntu-xenial] Error 2
> Please advise
> -Jon

More information about the Open-ils-general mailing list