[OPEN-ILS-GENERAL] Reporting module appears stuck

JonGeorg SageLibrary jongeorg.sagelibrary at gmail.com
Sat Jun 1 18:12:36 EDT 2019

Greetings, I've run into an issue where the reporting module does not
appear to want to restart.

Reports are run on the log server against the replicated database server.
Normally what I do is:

   - just restart it per
   opensrf user

I've also done the following:

   - Restarted all osrf services on the application and log servers along
   with ejabberd/memcached where applicable.
   - Killed all processes on the database server older than 2 minutes.
   - Re-ran replication of the production server to replicated database
   server. I did this just to rule out that there was not an issue with the
   replicated copy because we did have a fines issue that was related to the
   replication at one point.
   - I ran "SELECT now()-query_start,pid,state,application_name,waiting
   FROM pg_stat_activity;" but had to remove ",waiting" as it threw an error.
      - That returns a list of processes like open-ils.cstore,
      open-ils.pcrud, open-ils.reporter-store and the like. I attempted to kill
      the old reporter-store processes with the command "SELECT
      pg_cancel_backend(backend_pid);" and Clark stopped, and while it
returned a
      value of true showing the process was dead, when I re-ran it, it
appears to
      still be present.

I don't see anything else under
or https://wiki.evergreen-ils.org/doku.php?id=scratchpad:random_magic_spells

The only thing I haven't tried, but shouldn't need to, is to actually
restart that server, but am waiting until there is someone physically
present in case it does not properly restart on its own.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://libmail.georgialibraries.org/pipermail/open-ils-general/attachments/20190601/9fd0599f/attachment.html>

More information about the Open-ils-general mailing list