[OPEN-ILS-GENERAL] 1.4 RC1 - config.cgi

Dan Scott denials at gmail.com
Fri Oct 24 07:51:27 EDT 2008

2008/10/21 Warren Layton <warren.layton at gmail.com>:
> I'm trying to run cgi-bin/config.cgi from my browser but I keep
> getting "500 Internal Server Error". When this error occurs, the
> following message is appended to my Apache 2 error log:
>      [Tue Oct 21 21:45:31 2008] [error] [client] Premature
> end of script headers: config.cgi
> This is likely my fault and I'm assuming that I have misconfigured my
> <Directory> section in /etc/apache2/sites-available/eg.conf. For
> testing, I tried to "Allow from all":
>  Alias /cgi-bin/ "/openils/var/cgi-bin/"
>  <Directory "/openils/var/cgi-bin">
>         AddHandler cgi-script .cgi .pl
>         AllowOverride None
>         Options FollowSymLinks ExecCGI Indexes
>         Order allow,deny
>         Allow from all
>  </Directory>
> ...but I still get the same error.
> Likely a silly misconfiguration of my own making, but just in case...

No, not at all. It turns out that this is a regression introduced in
OpenSRF; if either the osrf_json_gateway or osrf_http_translator
Apache modules are enabled, then CGI support in Apache is broken.

Of course, both modules are required for Evergreen 1.4 to function. So
- anyone want to start bisecting the changes in OpenSRF, testing just
osrf_json_gateway and a minimalist CGI configuration to determine what
commit introduced the regression? I can vouch that this was working as
of May 2008, as I have a working system that dates back to that time.

And if there are any testing fans out there with some time on their
hands to contribute to the project, this would be a great opportunity
to help set up a framework to help catch these problems early in the
development cycle...

Dan Scott
Laurentian University

More information about the Open-ils-general mailing list