[OPEN-ILS-GENERAL] importing batch authority records

Chris Caughey CCaughey at jessup.edu
Fri Dec 4 13:39:15 EST 2009

Hi Jason and Repke,

I don't know if this will mean anything to either of you (or anyone else
who reads this).  I'm including the text of an email our former IT
support staff sent to the developers' listserv.

Hi all.  I'm running into an error when importing authority records
using the staff client, on EG  Any light you can shed on this
situation would be much appreciated.

I'm not sure if our database has an incorrectly defined arn_value column
in the authority.record_entry table, or if the authority record import
routine is expecting some additional data in the authority record source
files being imported.  It might be helpful to mention that there is only
a single row listed in the staff client under "edit attributes" for
authority records.

The specific error message we're getting is in the Postgres log:

2009-11-16 08:40:27 PST ERROR:  null value in column "arn_value"
violates not-null constraint

This error occurs during the import when an INSERT like this is

eleted,edit_date,editor,id,last_xact_id,marc,source) VALUES
xsi:schemaLocation="http://www.loc.gov/MARC21/slim http://www.loc.gov/
standards/marcxml/schema/MARC21slim.xsd"><leader>00271nz  2200109n
tag="005">20010515160026.0</controlfield><controlfield tag="008">010515
n anannbabn           a ana     d</controlfield><datafield tag="040"
ind1=" " ind2=" "><subfield code="a">SJCC</subfield><subfield
code="c">SJCC</subfield></datafield><datafield tag="150" ind1=" " ind2="
"><subfield code="a">Russian Orthodox
Church.</subfield></datafield><datafield tag="550" ind1=" " ind2="
"><subfield code="a">Christian 

Executing describe on the authority.record_entry table reveals:

Column    |           Type           |
 id           | bigint                   | not null default
 arn_source   | text                     | not null default
 arn_value    | text                     | not null
 creator      | integer                  | not null default 1
 editor       | integer                  | not null default 1
 create_date  | timestamp with time zone | not null default now()
 edit_date    | timestamp with time zone | not null default now()
 active       | boolean                  | not null default true
 deleted      | boolean                  | not null default false
 source       | integer                  |
 marc         | text                     | not null
 last_xact_id | text                     | not null


Message: 5
Date: Fri, 4 Dec 2009 17:47:03 +0100
From: Repke de Vries <repke at xs4all.nl>
Subject: Re: [OPEN-ILS-GENERAL] importing authority records
To: Evergreen Discussion Group
	<open-ils-general at list.georgialibraries.org>
Message-ID: <8227A318-1151-4944-968C-2DB2C92679A8 at xs4all.nl>
Content-Type: text/plain; charset=WINDOWS-1252; delsp=yes;

Hi Chris, hi Jason

meanwhile Chris answered further [1]  but answering Jason's to keep  
the thread on this issue together.

My library (evaluating Evergreen) is also struggling with (Vandelay)  
authority batch import and I have emailed this list on exactly the  
same phenomenon in  all fine 'till the actual import and a  
progress bar that sits still at 0 % and nothing getting imported.

Chris: here are some results from trying the same on Dan Scott's virtual image [2] on my iMAC as an 1.6 implementation example  
and with  a small subset of  our IISH authority records for the bib  
record MARC 100 field; this subset is available as test set in the  
Evergreen SVN [3]:

1) at first same story after selecting just one of the authority  
records and ask for Import Selected: progress bar sits at 0 % and  
just trying Validating or Right Mouse Click in a new bib record in  
the 100 field doesn't do anything

2) then I tried "Import all" and all of a sudden it did work and all  
17 records got reported as Imported (you have to leave the Batch  
Importer and go back to it again and to Inspect Queue etc. to  
actually see the change) and trying out in new bib record worked fine  

3) next trials were first a large set of  Authority MARC 400 records  
which did  upload but *not* import and then a small subset of the  
same (someone with SVN access could add that test set - let me know  
off list) which did *not* import either:  progress bar sitting for  
ever at  0 % (and nothing reported as imported)

4) however:  at some point I just tried to use it in a new MARC  
record and there they were the 400 authority data ??!!

So: a dead progress bar sometimes means "nothing happened", sometimes  
it means nothing at all and authority data do find their way into the  

I have no clue what causes all this and inspected the Postgres  
database log, see no errors (I think) but lack the expertise to  
interpret what happens or does not happen at that level.

Vandelay / batch importing authority records  seems an unpredictable  
roller coaster. Anybody ideas ?
I can send you my  Postgres log or ay other of the EG logs.

Repke de Vries, IISH

[1] December first:
Hi Jason,

No, I haven't.  I'm just the cataloger at WJU, and Jeff, our IT guy who
did our data migration and Evergreen installation, just accepted a job
elsewhere.  Has anyone else had trouble with importing authority records
in  Will upgrading to 1.6 solve this?


[2] Downloadpage http://evergreen-ils.org/downloads.php   under  
"Other versions of Evergreen software"

[3] called "auth-subset100.mrc" at http://svn.open-ils.org/trac/ILS/ 

Op 1-dec-2009, om 17:24 heeft Jason Etheridge het volgende geschreven:

> On Tue, Nov 24, 2009 at 11:51 AM, Chris Caughey  
> <CCaughey at jessup.edu> wrote:
>> We were having trouble using the authority batch import.  The  
>> whole process
>> would move along without incident until it came to the progress  
>> bar.  Then
>> it would sit at 0% and do nothing indefinitely.  Last week, we  
>> upgraded to
>>, and now the progress bar moves a little bit, but then it  
>> stalls out
>> again.  Our IT department tells me that Evergreen is showing an error
>> related to ?arn_value.?  Has anyone else experienced this  
>> problem?  If so,
>> what did you do to fix it?
> Hey Chris, did you make any headway on this?
> -- 
> Jason Etheridge
>  | VP, Tactical Development
>  | Equinox Software, Inc. / The Evergreen Experts
>  | phone:  1-877-OPEN-ILS (673-6457)
>  | email:  jason at esilibrary.com
>  | web:  http://www.esilibrary.com
> Please join us for the Evergreen 2010 International Conference,  
> April 20-23,
> 2010 at the Amway Grand Hotel and Convention Center, Grand Rapids,  
> Michigan.
> http://www.evergreen2010.org/

End of Open-ils-general Digest, Vol 42, Issue 10

More information about the Open-ils-general mailing list