[OPEN-ILS-GENERAL] installation question

Jesse Ephraim jephraim at roanoketexas.com
Wed Mar 31 22:20:12 EDT 2010

I reinstalled Debian Lenny with no problems.

I am partway through installing OpenSRF, to the point where I need to set up the Jabber users.  After making the appropriate changes to ejabberd.cfg, I restarted ejabberd, as per the instructions.

When I issued this command

roanoke:/etc/ejabberd# ejabberdctl register router private.localhost unique

I got:

RPC failed on the node ejabberd at roanoke: {'EXIT',

I triple-checked ejabber.cfg to make sure I covered all the steps in changing it, and it looks fine.

Oddly enough, I didn't have any problems installing OpenSRF and testing it the first time I tried it.

Also, at this point in the installation JSON.pm is still not in /usr/local/share/perl/5.10.0/OpenSRF/Utils/JSON.pm.  
Does that get installed later?

Any help would be appreciated!


-----Original Message-----
From: open-ils-general-bounces at list.georgialibraries.org on behalf of Jason Etheridge
Sent: Tue 3/30/2010 12:26 PM
To: Evergreen Discussion Group
Subject: Re: [OPEN-ILS-GENERAL] installation question

I found my JSON.pm here: /usr/local/share/perl/5.10.0/OpenSRF/Utils/JSON.pm

> What should $PERL5LIB have in it?

I have /openils/lib/perl5:

> Do you think I should re-install OpenSRF?  If so, should I just install over the current one, or do something to remove the current one?

I would, if JSON.pm isn't in /usr/local/share.  Installing OpenSRF
over top of OpenSRF should be fine.

Jason Etheridge
 | VP, Tactical Development
 | Equinox Software, Inc. / The Evergreen Experts
 | phone:  1-877-OPEN-ILS (673-6457)
 | email:  jason at esilibrary.com
 | web:  http://www.esilibrary.com

Please join us for the Evergreen 2010 International Conference!
It is being held April 20 - 23, 2010 at the Amway Grand Hotel and
Convention Center, Grand Rapids, Michigan.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/ms-tnef
Size: 4245 bytes
Desc: not available
Url : http://libmail.georgialibraries.org/pipermail/open-ils-general/attachments/20100331/2886d347/attachment-0001.bin 

More information about the Open-ils-general mailing list