[OPEN-ILS-GENERAL] OpenSRF / Evergreen assistance

JonGeorg SageLibrary jongeorg.sagelibrary at gmail.com
Fri Aug 17 19:24:06 EDT 2018

Alright, I was just trying to keep it off the listserv - the error I kept
getting was

opensrf at sage:/$ osrf_control --localhost --start-all
Use of uninitialized value $@ in concatenation (.) or string at
/usr/local/share/perl/5.22.1/OpenSRF/Transport/SlimJabber/Client.pm line
Exception: OpenSRF::EX::Jabber 2018-08-15T11:05:01
Jabber Exception: Could not authenticate with Jabber server:

which is supposed to be resolved by making sure that the
variable is set in the opensrf ~/.bashrc which it was.

On Fri, Aug 17, 2018 at 4:19 PM, Jason Stephenson <jason at sigio.com> wrote:

> On 08/17/2018 07:03 PM, JonGeorg SageLibrary wrote:
> > I'm simply stating that on this server that was the setting that
> > prevented me from continuing in case someone gets the same error.
> JonGeorg,
> It would be helpful for you to share the exact errors message on the
> list. Otherwise, no one will know if they get the same error.
> Plus, the list is archived and eventually indexed by Google, so it will
> be helpful also for anyone searching the error message to turn up this
> conversation.
> I still don't see how OpenSRF could possibly be working with SCRAM
> authentication, but you say it is, so I won't argue the point.
> Cheers,
> Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://libmail.georgialibraries.org/pipermail/open-ils-general/attachments/20180817/fb8f1f57/attachment.html>

More information about the Open-ils-general mailing list